Blbnoucí balíčky po upgradu z ubuntu-server 12.04 na 14.04

Vypadá to nějak takto:

Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
 db5.1-util g++-4.6 gfortran-4.6 html2text libboost-iostreams1.46.1
 libclass-isa-perl libgd2-xpm libgeos-3.2.2 libgeos-3.3.3 libicu48
 libkadm5clnt-mit8 libkadm5srv-mit8 libkdb5-6 libllvm3.0 libmpc2
 libstdc++6-4.6-dev libswitch-perl libt1-5 libtasn1-3-dev libyaml-syck-perl
 python-authres python-central python-dns python-spf update-inetd
Pro jejich odstranění použijte „apt-get autoremove“.
0 aktualizováno, 0 nově instalováno, 0 k odstranění a 1 neaktualizováno.
4 instalováno nebo odstraněno pouze částečně.
Po této operaci bude na disku použito dalších 0 B.
Nastavuji balík apache2 (2.4.7-1ubuntu4.10) …
Directory /etc/apache2/conf.d is not empty - leaving as is
Please note, that directory is considered obsolete and not read anymore by default
munin phpmyadmin.conf phppgadmin phppgadmin.dpkg-new
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
ERROR: Module filter not properly enabled: /etc/apache2/mods-enabled/filter.load is a real file, not touching it
ERROR: Could not enable dependency filter for deflate, aborting
dpkg: error processing package apache2 (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 1
dpkg: nesplněné závislosti zamezily konfiguraci balíku libapache2-mod-php5:
 libapache2-mod-php5 závisí na apache2 (>= 2.4); avšak:
 Balík apache2 zatím není zkonfigurován.
dpkg: error processing package libapache2-mod-php5 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že se jedná o chybu způsobenou předchozí chybou.
 dpkg: nesplněné závislosti zamezily konfiguraci balíku php5:
 php5 závisí na libapache2-mod-php5 (>= 5.5.9+dfsg-1ubuntu4.17) | libapache2-mod-php5filter (>= 5.5.9+dfsg-1ubuntu4.17) | php5-cgi (>= 5.5.9+dfsg-1ubuntu4.17) | php5-fpm (>= 5.5.9+dfsg-1ubuntu4.17); avšak:
 Balík libapache2-mod-php5 zatím není zkonfigurován.
 Balík libapache2-mod-php5filter není nainstalován.
 Balík php5-cgi není nainstalován.
 Balík php5-fpm není nainstalován.
dpkg: error processing package php5 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že se jedná o chybu způsobenou předchozí chybou.
 dpkg: nesplněné závislosti zamezily konfiguraci balíku phpmyadmin:
 phpmyadmin závisí na libapache2-mod-php5 | libapache2-mod-php5filter | php5-cgi | php5-fpm | php5; avšak:
 Balík libapache2-mod-php5 zatím není zkonfigurován.
 Balík libapache2-mod-php5filter není nainstalován.
 Balík php5-cgi není nainstalován.
 Balík php5-fpm není nainstalován.
 Balík php5 zatím není zkonfigurován.
dpkg: error processing package phpmyadmin (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože již byl dosažen MaxReports
 Při zpracování nastaly chyby:
 apache2
 libapache2-mod-php5
 php5
 phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)

ŘEŠENÍ

Zajet do

/var/lib/dpkg/info

a přesunout někam do háje třeba do /root/info/

soubory balíčků uvedených v chybě, tedy:

cd /var/lib/dpkg/info
mkdir /root/info/
mv apache2* /root/info/
mv libapache2-mod-php5* /root/info
mv php5* /root/info
mv phpmyadmin* /root/info
zdroj

 

Příspěvek byl publikován v rubrice BugFAQ, Linux a jeho autorem je mirra. Můžete si jeho odkaz uložit mezi své oblíbené záložky nebo ho sdílet s přáteli.

Autor: mirra

Hardwaru a počítačům se věnuji již od roku 2003. Za tu dobu jsem poskládal stovky počítačů, opravil tisíce počítačů a vyřešil nespočetně problémů, vad a chyb, se kterými se setkávali uživatelé. Od roku 2005 se zabývám servery, zejména těmi herními , v roce 2007 jsem se začal věnovat Valve Source SDK level designu, který šel od roku 2009 k ledu kvůli studiu Informatiky na univerzitě. Podílel jsem se chvíli i na provozu síťové laboratoře MENDELU, dnes spravuji cca 13 serverů/diskových polí na univerzitě, řeším IT v malých a středních firmách tak, aby firmy ušetřily nemalé částky při zlepšení kvality a soustředím se na snižování nákladů na IT od licencí až po hardware, software, provádím konsolidace a audity platnosti licencí, které firmám šetří rovněž nemalé peníze. Velké firmy nechávám korporacím. ;-)

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *

Captcha *